Заменил файлы ru/LC_MESSAGES/ django.mo django.po, но OSQA переключилась на английский...

Подскажите как ее переключить на русский ?

D файле settings_local.py следующая настройка LANGUAGE_CODE = 'ru'

Так же побывал выполнить следующий команду:

sudo python manage.py makemessages -l ru -e html,txt -e xml

пишет следующие:

processing language ru

Error: errors happened while running xgettext on init.py

/bin/sh: xgettext: not found

задан 29 Фев '12, 12:00

maxwelhelp's gravatar image

maxwelhelp
402914
Одобрено: 25%

изменено 29 Фев '12, 12:40

Установил gettext

apt-get install gettext

После чего выполнил команду

django-admin.py makemessages -l ru -e html,txt -e xm

Пишет ошибку:

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9811: keyword "id" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9811: keyword "server_response_time" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9811: keyword "data" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9811: keyword "time" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9811: keyword "data" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9811: keyword "host" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9811: keyword "fe7" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9811: keyword "span" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9812: keyword "body" unknown

/home/osqa/osqa-server/locale/ru/LC_MESSAGES/django.po:9813: keyword "html" unknown

msgmerge: found 38430 fatal errors

(29 Фев '12, 12:38) maxwelhelp maxwelhelp's gravatar image

тут даже не знаю ... это надо смотреть - может ошибки в шаблонах самих ... у меня строки собирает без проблем вроде.

(29 Фев '12, 12:49) Berg ♦♦ Berg's gravatar image

xgettext: not found говорит что надо поставить xgettext

У меня для работы русского настроено вот так..

# Language code for this installation. All choices can be found here:
# http://www.i18nguy.com/unicode/language-identifiers.html
LANGUAGE_CODE = 'ru'

from django.utils.translation import ugettext_lazy as _
LANGUAGES = (
             ('en', _('English')),
             ('ru', _('Russian')),
)
USE_I18N = True
USE_L10N = True

ошибка ImportError: No module named MySQLdb говорит о том, что у вас не установлен модуль питона для работы с базой MySQL пакет линукса python-mysqldb ( или pip install mysql-python)

так же рекомендую проверить что верно настроена база в настройках для mysql

DATABASES = {
    'default': {
        'ENGINE': 'django.db.backends.mysql', 
        'NAME': 'db_name',                    
        'USER': 'db_user_name',                 
        'PASSWORD': 'db_pass',                  
        'HOST': 'localhost',                  
        'PORT': '',                      # Set to empty string for default.
        'OPITIONS': {
                     'init_command' : 'SET NAMES "utf8"',
                     }        
    }
}
Постоянная ссылка

отвечен 29 Фев '12, 12:43

Berg's gravatar image

Berg ♦♦
5565813
Одобрено: 77%

изменено 29 Фев '12, 12:45

Так у меня база Postgres

(29 Фев '12, 12:57) maxwelhelp maxwelhelp's gravatar image

А а в каком файле (settings_local.py ?) писать настройку

from django.utils.translation import ugettext_lazy as _ LANGUAGES = ( ('en', ('English')), ('ru', ('Russian')), ) USE_I18N = True USE_L10N = True

(29 Фев '12, 13:05) maxwelhelp maxwelhelp's gravatar image

да, можно в файле settings_local.py.

ну я вам написал про базу так как вы показали такую ошибку изначально, а она говорит, что где-то еще использовалась настройка для mysql. а для postgresql лучше использовать postgresql_psycopg2

DATABASES = { 'default': { 'ENGINE': 'django.db.backends.postgresql_psycopg2', 'NAME': 'db_name',
'USER': 'db_user_name',
'PASSWORD': 'db_pass',
'HOST': 'localhost',
'PORT': '',
} }

(29 Фев '12, 13:14) Berg ♦♦ Berg's gravatar image

у меня строки собирает без проблем когда я заменяю файлы django.mo django.po, на стандартные

(29 Фев '12, 13:16) maxwelhelp maxwelhelp's gravatar image

Так да вот мои настройки

DATABASES = { 'default': { 'ENGINE': 'django.db.backends.postgresql_psycopg2',

    'NAME': '*****',
    'USER': '*****',
    'PASSWORD': '*****',
    'HOST': '*****',
    'PORT': '*****',

А где она ище может использоваться ?

(29 Фев '12, 13:19) maxwelhelp maxwelhelp's gravatar image

Да может и просто settings_local.py не подключался ? а в settings.py было прописано ...

(29 Фев '12, 13:25) Berg ♦♦ Berg's gravatar image
показать 5 из 6 show 1 more comments

Вопрос решен.... (просто не так файл скачал =) )

вот что нужно было сделать

  1. Скачать нормальный русский перевод здесь

  2. Открыть файл django.po Заменить все значения /bht/ на /default/ (/Название темы/ )

  3. Заменил файлы django.mo django.po,на скачанные /osqa-server/locale/ru/LC_MESSAGES

  4. в файле settings_local.py следующая настройка LANGUAGE_CODE = 'ru'

  5. Выполнил команду sudo django-admin.py makemessages -l ru -e html,txt -e xml

  6. Перезагрузить Апач sudo /etc/init.d/apache2 restart

Постоянная ссылка

отвечен 29 Фев '12, 15:50

maxwelhelp's gravatar image

maxwelhelp
402914
Одобрено: 25%

Ваш ответ
включить просмотр

Следить за вопросом

По Email:

После авторизации вы сможете подписаться на любые обновления здесь

По RSS:

Ответы

Ответы и комментарии

Основы Markdown

  • *italic* or _italic_
  • **bold** or __bold__
  • ссылка:[текст](http://url.com/ "заголовок")
  • изображение?![alt текст](/path/img.jpg "заголовок")
  • нумерованый список: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • основные теги HTML, также поддерживаются

Теги вопроса:

×9
×2
×2
×1
×1
×1

заданые вопросы: 29 Фев '12, 12:00

просмотренные вопросы: 5,271 times

последние обновления: 29 Фев '12, 15:50